majdnem minden ami ReTRo

új B2000 alaplap

2012/12/31. - írta: Сергей

...következzen az év utolsó cikke, egészen rövid leszek. Szükségem van működő AMIGA 2000-es alaplapra, teszt célokra. Itthon, mint szinte bármit, ezt is nehézkes beszerezni... Gondoltam, szétnézek az ebay.de-n... most szerencsém volt, mindjárt kettőt is sikerült lőni belőle, egy viszonylag szép állapotú Rev 4.1-et és egy nagyon romos Rev 4.4-et. :-) Mind a két alaplapon jól látszik, hogy kifolyt a valós idejű órához rendszeresített hengerakkumulátor és a folyadék savtartalma oxidálta a foglalatok, vagy a réz vezetékek egy részét. Érdekes módon, komolyabb sav-káros B2000 alaplap sikeres javításáról nem nagyon találtam cikket. Ezek szerint ez nem is olyan egyszerű feladat, mint amilyennek első ránézésre tűnik...

Először a szebb állapotú lapot néztem át, ahhoz első ránézésre sem fűztem sok reményt. Látszik rajta, hogy valaki nagyon szenvedett a javításával, szinte minden TTL logikai IC foglalatos rajta (10 db nem gyári foglalat van rajta). Így nem lesz egyszerű dolgom, minden utólagos megoldást alaposan ki kell mérni... Minden esetre zárlatmentesítettem a COM1, COM2, billentyűzet csatlakozó környékét, ki lettek szedve a csatlakozók és nem igazán voltak rendben. Bekapcsolás után zöld képernyőt (ram hiba) kaptam eredményül, ami sajnos nem stabil (folyton újra indult a gép, de nem a normál ütemben), tehát más gondja is van. Ezt bizony félreraktam, ha majd nagyon sok időm lesz folytatom...

Megnéztem az első látásra reménytelennek tűnő alaplapot is, íme a kezdeti állapota. A CPU és a KS ROM IC foglalatának érintkezőit szétmarta a sav (a műanyag részét valaki letörte róla), a bal oldalon lévő 86 tüskés CPU bővítő slot szintén zölden virít:

sav01.jpg

Következett a javítási kísérlet... A forrasztópákám és egy csipesz segítségével eltávolítottam a oxidálódott tüskéket az alaplap galvanizált lukaiból.

sav02.jpg

Majd egy nagyon alapos tisztítás következett, többször befújtam az egészet kontakt sprayvel, átdörzsöltem egy erős sörtéjű fogkefével és addig törölgettem konyhai papírtörlő és fültisztító pálcika segítségével, amíg tiszta nem lett. Természetesen ezt a műveletet elvégeztem a nyomtatott áramköri lap mindkét oldalán, íme az eredmény:

sav03.jpg


Fogtam a multimétert és egyesével kiméregettem minden lukat először alul - felül, majd a CPU slot - 68K foglalat, a 68K foglalat - KS ROM foglalat és a KS ROM foglalat - AGNUS irányába. Akár milyen hihetetlen, mindegyik galván épen maradt, egyiket sem kellett kihuzaloznom. Az alaplap alján találtam egy vezeték sérülést, amit fixáltam (az valami más balesetből adódott). Ezek után fogtam a forrasztópákát és beforrasztottam egy 64 és egy 40 lábú precíziós foglalatot. A másik alaplapból kipöccintettem a 68000-et és a KS ROM IC-t és beletettem... 

sav04.jpg

Kapcsoljuk be... a gyári 1.3 KS ROM IC-vel nem volt hajlandó indulni, végül egy kölcsönzött 2.05-el sikerült. Egy újabb alaplap, ami legalább egy évtizedet töltött hamvaiban, viszonylag simán életre kelt...

ram.jpg

A történet egyenlőre még nem végződött a főhősnőre (AMIGA) nézve teljesen pozitívan... A lap nem túl stabil, időközönként sárga, vagy piros hibaképernyővel indul el és egyenlőre nem találom a hiba okát. Ha rápillantunk a WB 1.3 fejlécére, akkor látjuk, hogy a szabad memória 300Kb körül van és nincs belőle több. Azt hiszem rá fogok keresni az IC nélküli Rev 6.2-es lapokra, hátha találok...

Szólj hozzá!

A bejegyzés trackback címe:

https://szergitata.blog.hu/api/trackback/id/tr344988480

Kommentek:

A hozzászólások a vonatkozó jogszabályok  értelmében felhasználói tartalomnak minősülnek, értük a szolgáltatás technikai  üzemeltetője semmilyen felelősséget nem vállal, azokat nem ellenőrzi. Kifogás esetén forduljon a blog szerkesztőjéhez. Részletek a  Felhasználási feltételekben és az adatvédelmi tájékoztatóban.

Nincsenek hozzászólások.