majdnem minden ami ReTRo

B2000 Com2 port javítás

2012/03/18. - írta: Сергей

...két bejegyzéssel ezelőtt írtam, hogy szétszedtem a B2000-et, mert nem szerettem volna tovább halogatni a hengerakkumulátor kioperálását. Észleltem, hogy a (joystick kezelésére szolgáló) Com2 portja egyrészt csúnyán néz ki, másrészt egyáltalán nem működik. Ahogy az már lenni szokott ez nem hagyott nyugodni, pontosabban addig nem akartam újra összerakni a gépet, amíg az nem üzemel rendesen. Elkezdtem keresni a hibát ezerrel, összességében hat órát biztosan küzdöttem vele, hogy miért tartott ilyen sokáig, az hamarosan kiderül...

hack01.jpg


Az alap feltevésem az, hogy a Com1-Com2 port működése azonos (általában egeret és joystickot, vagy két joystickot kezel), ezért mivel a Com1 működik, az itt mért értékeknek kéne lennie a Com2-n is...
A Com1 - 1,2,3,4,5,6,7,9-es lábán mérhető volt a feszültség, a 8-as földön van, ehhez képest a Com2 1,2,3,4,6,7-en volt áram és az 5,8,9 láb volt földön... :-P

Csináltam szakadás vizsgálatot mindkét csatalakozón és környékén, kiderült, hogy a Com2 huzalozásánál két drót meg volt cserélve. Ezeket a helyükre forrasztottam, újabb szakadás vizsgálat következett, melynek tanulsága szerint minden jó, de a joystick továbbra sem ment. Tehát tovább kell keresni a hibát, mi a helyzet ronda kék színű EMI2xx számozású emi zavarszűrőkkel (én idétlen kivitelű diódának véltem őket, szerencsére Flex99 felvilágosított, hogy zavarszűrők).
Rámértem a lábaikra, mindegyiken van feszültség kivéve az EMI239-EMI240-en. Követtem tovább a két track-et, egy négyes csoport kerámia kondenzátorhoz vezet. Itt is az a helyzet, a C213-C210 közül a C213 és C212-n nem mérhető semmi. A Com2 5-ös és 9-es lába az EMI239-240-en és a C213-C212-n keresztül rá van kötve a PAULA-ra. Kivettem az idős nénit, hátha a custom chip a ludas, tettem be egy másikat, de sajnos a jelenség ugyan az maradt. Bedühödtem, másik joy-t is próbáltam, szintén semmi...

Van egy J200 nevű jumper az alaplapon, amiivel a fényceruza beállításait lehet elvégezni, azt is kipróbáltam mindkét állásban (sőt le is vettem), semmi eredmény. A lap szélén lévő három ellenállás hidat, AP200, AP204, AP205 szintén kimértem, mindegyiken folyt áram, az jó, mert bennem is jócskán.
Először a két EMI-t cseréltem ki, majd a két kondenzátort is, a helyzet változatlan maradt, ott ahol a feszültségnek kéne lenni (nem bennem, a csatlakozóban), nem volt semmi...

Neki álltam egy működő AMIGA 500 REV6-ot szintén hasonló módon kiméregetni, ez sem hozott túl sok eredményt, maximum annyit, hogy ráterelődött a gyanúm az U202 alias 74LS157 TTL logikára, két lábán gyanúsan alacsony volt a feszültség szint. Ezen felbuzdulva kiforrasztottam az U202-t, megtisztítottam a helyét és tettem be egy foglalatot.

ttl.jpg
foglalat.jpg


Egy marék 157-es TTL-el kipróbáltam és találtam köztük olyat, ahol javult a feszültség szint (jelenleg is az az IC van a gépben), de a joystick még mindig nem működött.

Végső elkeseredésemben fogtam és kiforrasztottam a DSUB9-es csatlakozót... A látvány ami fogadott leírhatatlan volt! Ősidők óta nem láttam ilyet, mivel lehetett ezt anno így elkezelni? :-(

Ez horror (katt):
com2galván.jpg


A csatlakozót pillanatragasztóval ragasztották a nyomtatott áramkörhöz (melegítésre szerencsére engedett), a kilenc darab luk galvánjából három volt ép, de kiméréskor azok is szakadást mutattak. Ráadásul ez egyik lukgalván a trackjával együtt hozzá ért a szomszédos lábhoz, jó kis megfoghatatlan zárlatot okozva ezzel. Ami pedig überelhetetlen (emiatt szívtam ekkorát) az az, hogy a csatlakozó egyik tüskéje már a beszerelés előtt el volt törve és egy "ügyes kezű" szaki megforrasztotta. Így mérésnél érintkezett, de amit rádugtam valamit, azonnal elmozdult a helyéről (ha ez nincs, akkor hamarabb "látható" lett volna a hiba). :-P Hm... Tettem be másik DSUB9-es csatlakozót, újra kivezetékeltem a kilenc forrszemet (a galvánokat nem volt kedvem kihuzalozni, mert le kellett volna bontani hozzá minden alkatrészt a környéken) közvetlen az EMI-k lábához, majd az egészet ismét megmértem kétszer is. Láss csodát, a C213-C212-en és a TTL-en is megkerült a hiányzó feszültség. Kipróbáltam joystickkal is a gépet, szépen működik rajta minden. Nem gyenge hajtépés volt, de megérte (köszönöm a tanácsokat Geek-nek és Flex99-nek)! :-D
Apropó a takarítás és hajtépés... Végre nekiállhattam a B2000 alkatrészeket és a hozzá tartozó összes kártyát beszerelni egyetlen dobozba, ez viszonylag könnyen és gyorsan sikerült is. Az már egy más kérdés, hogy a különböző Zorro kártyák működési sajátosságai miatt milyen szinten téptem a hajam, mire össze jött egy működő konfiguráció... :-P de ez már egy másik történet.

2 komment

A bejegyzés trackback címe:

https://szergitata.blog.hu/api/trackback/id/tr724324468

Kommentek:

A hozzászólások a vonatkozó jogszabályok  értelmében felhasználói tartalomnak minősülnek, értük a szolgáltatás technikai  üzemeltetője semmilyen felelősséget nem vállal, azokat nem ellenőrzi. Kifogás esetén forduljon a blog szerkesztőjéhez. Részletek a  Felhasználási feltételekben és az adatvédelmi tájékoztatóban.

dh1 2012.03.22. 11:02:43

Foto a vegeredmenyrol? :)

Сергей · http://szergely.sfblogs.net/ 2012.03.22. 11:33:05

@dh1: üdv a fedélzeten :-) nincs róla fotó, mert ritka ronda lett, így nem büszkélkedem vele :-) aznap este a lényeg már csak az volt, hogy működjön... ;-)